"Login Failed For User 'SA'" Error When Logging Into TimeForce

Problem:

After logging in, a "Page cannot be displayed" error comes up with the following Technical Information at the bottom of the screen:

Error Type:

Microsoft OLE DB Provider for SQL Server (0x80040E4D)

Login failed for user 'sa'.

/qqest/include/Security.asp, line 6

Cause:

The SQL username and/or password is incorrect.  This is caused when the user entered an incorrect SQL username or password during an "Advanced" installation.  

It is also possible on a typical install that the sa password was set to blank instead of the correct password.  In this scenario, call Tech Support at 1-800-697-7010.

Otherwise for Microsoft SQL Server 2000 users to correct this problem you must perform an "Advanced" installation of TimeForce and change the SQL username and password.

Solution:

Performing an Advanced TimeForce Installation:

Note:  It is strongly recommended that you make a backup of your TimeForce database before you perform an advanced installation.  See documentation on "Backing Up the TimeForce Database" for instructions on creating a database backup.

  1. Insert the TimeForce installation disk into your CD-ROM drive.  The installation main menu should automatically appear.  If it does not, open My Computer or Windows Explorer, browse to your CD-ROM drive, and click on "Setup.exe."

  2. From the Installation Menu click on the [TIMEFORCE INSTALLATION] icon.  The InstallShield Wizard opens and prepares to walk you through the installation process.
    Note
    :  At this point a "Confirm Uninstall" dialog box may appear asking if you wish to completely remove TimeForce and all of its components.  If this dialog box appears, you must uninstall the program before you will be allowed to run an advanced installation.  Do not uninstall the program until you have made a current backup of your TimeForce database.  You only need to uninstall TimeForce if this dialog box appears and prompts you to do so.  If no dialog box appears, move on to the next step.  Once the uninstallation is complete, begin the installation process at step #2.

  3. A "Welcome to the TimeForce Setup" screen opens.  Click on the [NEXT] icon to move on to the next screen.

  4. The "Software License Agreement" opens.  Browse through the agreement and click on the [YES] icon to move on to the next screen.
    Note
    :  You must accept the Software License Agreement before you will be allowed to continue the installation.

  5. The "Setup Type" screen opens.  By default Typical Setup (recommended) is selected.  Change this setting to Advanced Setup (SQL Server 2000 users).  Click on the [NEXT] icon to move on to the next setup screen.

  6. The "SQL Database Information" screen opens.  This screen asks you for two settings, Computer and Instance.  Leave these fields at their default settings of "(local)" for Computer and blank for Instance.  Click on the [NEXT] icon to move on to the next setup screen.

  7. The "User Name and Password" screen opens.  This screen is asking you for the SQL username and password.  By default, the SQL administrator user name is "sa." Enter two single quotes ( '' ) in the Password field to assume the default SQL password. If you are using SQL Server 2000, the password will be whatever password was chosen when SQL Server 2000 was installed. This is not the username and password for Timeforce or to log on to the PC.  Click on the [NEXT] icon.
    Note:
    Leaving the Password field will not assume the default SQL password.

  8. The "Installation Options" screen opens.  This screen gives you the option to install two components, TimeForce Program Files and TimeForce Database Files.  Ensure that both of the options are selected, and click on the [NEXT] icon to complete the installation.

  9. Once the installation has completed, click on the [FINISH] icon to close the InstallShield Wizard, and click on the [EXIT] icon to close the TimeForce installation menu.

You should now be able to open the TimeForce program and log in using your User Name and Password.